#!/bin/bash

# Copyright 2022, 2024  Patrick J. Volkerding, Sebeka, MN, USA
# Copyright 2022  Heinz Wiesinger, Amsterdam, The Netherlands
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
#    notice, this list of conditions and the following disclaimer.
#
#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

cd $(dirname $0) ; CWD=$(pwd)

PKGNAM=cargo-vendor-filterer
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
BUILD=${BUILD:-1}

# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
  case "$(uname -m)" in
    i?86) ARCH=i686 ;;
    arm*) readelf /usr/bin/file -A | egrep -q "Tag_CPU.*[4,5]" && ARCH=arm || ARCH=armv7hl ;;
    # Unless $ARCH is already set, use uname -m for all other archs:
    *) ARCH=$(uname -m) ;;
  esac
  export ARCH
fi

# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
  exit 0
fi

NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}

if [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=generic"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -march=x86-64 -mtune=generic -fPIC"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS=${SLKCFLAGS:-"-O2"}
  LIBDIRSUFFIX=${LIBDIRSUFFIX:-""}
fi

TMP=${TMP:-/tmp}
PKG=$TMP/package-$PKGNAM

rm -rf $PKG
mkdir -p $TMP $PKG

cd $TMP
rm -rf $PKGNAM-$VERSION
tar xvf $CWD/$PKGNAM-$VERSION.tar.?z || exit 1
cd $PKGNAM-$VERSION || exit 1
tar xvf $CWD/cargo-$PKGNAM-$VERSION.tar.?z || exit 1
mv cargo-$PKGNAM-$VERSION vendor

chown -R root:root .
find . \
  \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
  -exec chmod 755 {} \+ -o \
  \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
  -exec chmod 644 {} \+

# Configure cargo for offline builds
mkdir -p .cargo
cat << EOF >> .cargo/config.toml
[source.crates-io]
replace-with = "vendored-sources"

[source.vendored-sources]
directory = "vendor"
EOF

# rustix uses now by default linux_raw backend for syscalls, but seems supported only
# for aarch64, arm, mipsel, mips64el, powerpc64le, riscv64, x86, and x86_64.
# Re-add real errno for other architectures, or you can pass "--cfg=rustix_use_libc" 
# to force libc usage.
case "$ARCH" in
  mips|ppc|ppc64|s390x|loongarch64) 
    (cd vendor
     rm -rf errno
     tar xvf $CWD/errno-*.tar.lz
     #cd rustix
     #perl -n -e '
     #  if(m/dependencies.libc_errno/) { $status=1; }
     #  if($status && m/"0\.3\.1"/) {
     #	 s/"0.3.1"/"0.3.3"/;
     #	 $status=0;
     #  }
     #  print;
     #' Cargo.toml > Cargo.toml.tmp
     #\mv Cargo.toml.tmp Cargo.toml
     #cat .cargo-checksum.json  | perl -e '($newck)=split(" ",$ARGV[0]);while(<STDIN>) { s/("Cargo.toml":)"(\S+?)"/$1"$newck"/; print;}' `sha256sum Cargo.toml` > .cargo-checksum.json.tmp
     #\mv .cargo-checksum.json.tmp .cargo-checksum.json
    )
    #SLKRUSTFLAGS="--cfg=rustix_use_libc"
    ;;
esac

# Add support for EXT4 ioctl and FICLONE to loongarch64
#case "$ARCH" in
#  loongarch64|mips|ppc64|s390x) 
#    (cd vendor
#     cd rustix
#     zcat $CWD/rustix-syscall_loongarch64.diff.gz | patch -p3 --verbose
#     cat .cargo-checksum.json  | perl -e '($newck)=split(" ",$ARGV[0]);while(<STDIN>) { s|("src/backend/libc/io/syscalls.rs":)"(\S+?)"|$1"$newck"|; print;}' `sha256sum src/backend/libc/io/syscalls.rs` > .cargo-checksum.json.tmp
#     \mv .cargo-checksum.json.tmp .cargo-checksum.json
#    )
#  ;;
#esac

# Support for Loongarch64 in linux-raw-sys was introduced in 0.3.2, but rustix 
# targets version 0.1.2 (raised to 0.1.4). Replace version 0.1.4 with 0.4.3 and
# fix rustix Cargo.toml. See https://github.com/sunfishcode/linux-raw-sys/issues/34

RUSTFLAGS="$SLKRUSTFLAGS" \
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
OPENSSL_NO_VENDOR=1 \
cargo build \
  --offline \
  --release \
  $NUMJOBS || exit 1

mkdir -p $PKG/usr/bin
install -m 755 target/release/cargo-vendor-filterer \
  $PKG/usr/bin/ || exit 1

find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true

mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
cp -a *.md LICENSE \
  $PKG/usr/doc/$PKGNAM-$VERSION

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc

cd $PKG
/sbin/makepkg -l y -c n $TMP/$PKGNAM-$VERSION-$ARCH-$BUILD.txz